My GT won’t accelerate pass 20 mph!

Ogs550

Member
Joined
Apr 7, 2021
Messages
10
Reaction score
1
Location
Garner NC
First Name
Greg
Vehicle(s)
2015 GT premium
I have a 2015 Gt premium automatic ( not stock ). I can’t accelerate pass 20 mph. No check engine lights and when I use paddle shifters I only can go up to 3rd gear 4th does not work neither does any gear after 4rth. My sct device doesn’t pic up any codes wrong with the car but I plugged my friends codes reader in it gave me 6 codes. I researched all the codes and still can’t find a solution! Almost like my car is in limp mode with not check engine light at all! Need help asap as this is my daily car!





Advertisement

 

Cobra Jet

Well-Known Member
Joined
Feb 12, 2015
Messages
7,395
Reaction score
5,465
Location
NJ
Vehicle(s)
2018 EB Prem. w/PP and 94 Mustang Cobra
I have a 2015 Gt premium automatic ( not stock ). I can’t accelerate pass 20 mph. No check engine lights and when I use paddle shifters I only can go up to 3rd gear 4th does not work neither does any gear after 4rth. My sct device doesn’t pic up any codes wrong with the car but I plugged my friends codes reader in it gave me 6 codes. I researched all the codes and still can’t find a solution! Almost like my car is in limp mode with not check engine light at all! Need help asap as this is my daily car!
What are the codes you were able to extract with your f reader?

It sounds like the car is definitely in some type of limp mode.
 
OP
Ogs550

Ogs550

Member
Joined
Apr 7, 2021
Messages
10
Reaction score
1
Location
Garner NC
First Name
Greg
Vehicle(s)
2015 GT premium
  • Thread starter
  • Thread Starter
  • #3
What are the codes you were able to extract with your f reader?

It sounds like the car is definitely in some type of limp mode.
the codes are P068A, P2135, P2014, P2019, P2008, P2011, P061B. That’s what my friends reader picked up but I have no check engine light or any other lights displayed on the dash and again sct tuner not picking up any codes eaither
 

cmxPPL219

Well-Known Member
Joined
Feb 7, 2019
Messages
354
Reaction score
276
Location
Toronto, Canada
First Name
Eric
Vehicle(s)
2019 Mustang GT PP2
I have a 2015 Gt premium automatic ( not stock ). I can’t accelerate pass 20 mph. No check engine lights and when I use paddle shifters I only can go up to 3rd gear 4th does not work neither does any gear after 4rth. My sct device doesn’t pic up any codes wrong with the car but I plugged my friends codes reader in it gave me 6 codes. I researched all the codes and still can’t find a solution! Almost like my car is in limp mode with not check engine light at all! Need help asap as this is my daily car!
Did you try to unplug the battery for about 15-30mins?
 

cmxPPL219

Well-Known Member
Joined
Feb 7, 2019
Messages
354
Reaction score
276
Location
Toronto, Canada
First Name
Eric
Vehicle(s)
2019 Mustang GT PP2
yeah I did. Unplugged both positive and negative cables for 15 mins
Ok. When you used your friends code reader, did he just read the codes, or did you also clear the codes?
 

cmxPPL219

Well-Known Member
Joined
Feb 7, 2019
Messages
354
Reaction score
276
Location
Toronto, Canada
First Name
Eric
Vehicle(s)
2019 Mustang GT PP2
A quick look at those codes seems to indicate that you've got some Intake Manifold Runner actuator problem. One of the codes thrown is for throttle position sensor, so it all seems somewhat related.
 
OP
Ogs550

Ogs550

Member
Joined
Apr 7, 2021
Messages
10
Reaction score
1
Location
Garner NC
First Name
Greg
Vehicle(s)
2015 GT premium
  • Thread starter
  • Thread Starter
  • #8
Ok. When you used your friends code reader, did he just read the codes, or did you also clear the codes?
He read them off to me and I typed them all down in my phone then he cleared it. The problem first occurred when I was driving but still no engine light cut on when my car just stopped mid drive then that’s when we pulled over to the side of the highway and he read the codes
 
OP
Ogs550

Ogs550

Member
Joined
Apr 7, 2021
Messages
10
Reaction score
1
Location
Garner NC
First Name
Greg
Vehicle(s)
2015 GT premium
  • Thread starter
  • Thread Starter
  • #9
A quick look at those codes seems to indicate that you've got some Intake Manifold Runner actuator problem. One of the codes thrown is for throttle position sensor, so it all seems somewhat related.
yes indeed when in looked them up it didn’t give me a direct answer but I also so where it could be a blown fuse but the reply for the ecm you can’t tell if it’s blown or not. It’s just a black box looking fuse in the fuse box in the engine bay
 

BoostN IT

Well-Known Member
Joined
Feb 28, 2020
Messages
101
Reaction score
30
Location
OH
Website
www.boostseasonapparel.com
First Name
Drew
Vehicle(s)
2015 Ford Mustang GT Premium
Mhmm I will look into it. The performance to early code is exactly what came up when I checked for codes
Don't worry I know the issue. Make sure the pedal is pressed down all the way. haha jk
 

friedmud

Well-Known Member
Joined
Jan 25, 2021
Messages
183
Reaction score
190
Location
Idaho
Vehicle(s)
2019 Mustang GT
I have a 2015 Gt premium automatic ( not stock ). I can’t accelerate pass 20 mph. No check engine lights and when I use paddle shifters I only can go up to 3rd gear 4th does not work neither does any gear after 4rth. My sct device doesn’t pic up any codes wrong with the car but I plugged my friends codes reader in it gave me 6 codes. I researched all the codes and still can’t find a solution! Almost like my car is in limp mode with not check engine light at all! Need help asap as this is my daily car!
Any updates on this? Interested...
 
OP
Ogs550

Ogs550

Member
Joined
Apr 7, 2021
Messages
10
Reaction score
1
Location
Garner NC
First Name
Greg
Vehicle(s)
2015 GT premium
  • Thread starter
  • Thread Starter
  • #15
Any updates on this? Interested...
Any updates on this? Interested...
No updates as far as a answer to why my car is acting the way it is. I’ve been doing a lot of digging online for the codes it’s throwing. Auto gave me a print out of the list of codes it was throwing and the first code was P2135 - ignition on the PCM detected the difference between the throttle /pedal position sensor / switch A signal and the throttle / pedal position sensor /switch B signal was greater than the maximum allowable value
 

Advertisement





 
200 - Redline360 - 2


Advertisement
Top