Official Tesla-Style Head Unit

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
Blue connector is gps and i ran mine into the glove box.
And the white connector is antenna for radio? That white wire for me was only like 6 inches long and it looked like I was supposed to plug that into the head unit but the other end is supposed to plug into something else? But didn't know what.. any input would be appreciative.
Advertisement

 

elpatronvega

Active Member
Joined
Mar 6, 2017
Messages
36
Reaction score
10
Location
Chicago
Vehicle(s)
2017 mustang v6
So I have mine in. And it's great just haven't messed with it yet. Reverse and blue tooth and everything works. Trying to change the start up screen now. Only complaint is the radio is very fuzzy. Which plug on the back of the Gen2 is the antenna? I know there is a blue connector and white connector. I am going to try gps now while connected to the wifi next to my house
We're on the same boat. Can't keep my settings saved, radio fuzzy (white antenna was weird) and can't seem to change the boot screen
 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
We're on the same boat. Can't keep my settings saved, radio fuzzy (white antenna was weird) and can't seem to change the boot screen
Yeah I never hooked up the white cable for the antenna because I thought it connected to something but there was nothing to connect the cable to out of the head unit. Unless I am an idiot and it just sits back there But it looks like it is supposed to connect to something else.
 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
I changed the boot screen to one of the other default screens for now. When I am done downloading the update I'll video tape how to do it. I can see it taking multiple boot ups to take effect. I just turned the power on of the car, changed it, and I had to drive somewhere and came back and it was changed.
 

Drivinglesson

Well-Known Member
Joined
Feb 28, 2017
Messages
107
Reaction score
27
Location
Port Hueneme, CA
First Name
Sam
Vehicle(s)
2016 Ford Mustang GT
So is there a major difference between 1st gen and 2nd gen? I'm sorry I havent been following the thread for a while because of work and stuff.
The head unit itself is different, and the install harnesses are also different compared to the 1st gen. Software seems to be close.
 

2017PPGT

Well-Known Member
Joined
Mar 3, 2017
Messages
55
Reaction score
6
Location
Louisiana
First Name
Rick
Vehicle(s)
2017 PP GT w/ H-Pipe & Catback
And the white connector is antenna for radio? That white wire for me was only like 6 inches long and it looked like I was supposed to plug that into the head unit but the other end is supposed to plug into something else? But didn't know what.. any input would be appreciative.

Yes blue connector goes to blue plug in. And the white connector with the round black tube goes to white plug in. The black tube doesn't connect to anything.
 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
Yes blue connector goes to blue plug in. And the white connector with the round black tube goes to white plug in. The black tube doesn't connect to anything.
Interestinggg. Okay well I am an idiot. Thanks!!

also, [MENTION=20219]StangATX[/MENTION] , the update for Gen2 (April 2017) says that the compressed folder is empty? I go to download it and it says it will take 10-15 minutes and then it says it is done after a minute or two and I go to extract and it says there is nothing in the folder. Any info on this? Not sure if when the website when down, it didn't keep the file?
 

Drivinglesson

Well-Known Member
Joined
Feb 28, 2017
Messages
107
Reaction score
27
Location
Port Hueneme, CA
First Name
Sam
Vehicle(s)
2016 Ford Mustang GT
I've been at work all day but here is a quick update.
The wire they forgot to give me is an RCA and wouldn't affect sxreen coming on, so that is not the problem.
The HU A/C and pilot switches work, just not the screen.
It has been confirmed that I have everything connected correctly.
I checked the fuse in the car and it was fine, so that has been ruled out.
I will check the fuse on the HU when I get home and if that isn't it then the manufacturer says the brain is no good and I'll have to return it.
Pretty frustrating considering I was very laid back and wanted them to take their time and makensure it was ok.
My worse nightmare was having to ship it back out and it looks like a reality now.
I have to thabk StangATX for all of his help, as he went above and beyond.
I will definitely be donating again!

For anyone who wants the pic of oroper wire install, just hit me uo on what'sapp @ 504-421-5277.

Install is very very easy and it would've been an hour job with front camera if unit was working properly.
So no worries.
Hope I'm the only unfortunate one.
I have a 2016 base GT, and I am running the second generation. Here is a pic of the harnesses I received.

http://i1136.photobucket.com/albums/n493/drivinglesson/IMG_5725.jpg
 

Drivinglesson

Well-Known Member
Joined
Feb 28, 2017
Messages
107
Reaction score
27
Location
Port Hueneme, CA
First Name
Sam
Vehicle(s)
2016 Ford Mustang GT
We're on the same boat. Can't keep my settings saved, radio fuzzy (white antenna was weird) and can't seem to change the boot screen
What setting are you referring to? I had clock issues at first, and I thought my radio presets weren't holding, but I was wrong.
 

StangATX

Project Corrupted Cyclone
Joined
Dec 7, 2015
Messages
1,197
Reaction score
308
Location
Austin, TX
Vehicle(s)
2016 S550 White Corrupted Cyclone
Interestinggg. Okay well I am an idiot. Thanks!!

also, @StangATX , the update for Gen2 (April 2017) says that the compressed folder is empty? I go to download it and it says it will take 10-15 minutes and then it says it is done after a minute or two and I go to extract and it says there is nothing in the folder. Any info on this? Not sure if when the website when down, it didn't keep the file?
The download probably got corrupted. I double checked the archive and it works properly... Try another browser
 

StangATX

Project Corrupted Cyclone
Joined
Dec 7, 2015
Messages
1,197
Reaction score
308
Location
Austin, TX
Vehicle(s)
2016 S550 White Corrupted Cyclone
For the Radio I believe they forgot to include this harness. (it's from 1st gen) It seems that it'll do the trick...

Yh4vWH9.jpg
http://i.imgur.com/Yh4vWH9.jpg

I will try to contact the manufacturer for it.
 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
What setting are you referring to? I had clock issues at first, and I thought my radio presets weren't holding, but I was wrong.
I think he is referring to the whole antenna issue.

[MENTION=29186]2017PPGT[/MENTION] here is a picture of how I did mine. I disconnected the 4 clips for the center piece above the vents (it looks like a vent but it's just a cover) and ran the cable for the GPS up. I grinded down a little slot so the cable could stick out. Double sided tape the GPS antenna right next to the factory sensor. You can see it right by the front windshield.


Here is the one factory load up screen

 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
For the Radio I believe they forgot to include this harness. (it's from 1st gen) It seems that it'll do the trick...

Yh4vWH9.jpg
http://i.imgur.com/Yh4vWH9.jpg

I will try to contact the manufacturer for it.
Please do! I was going to say, seems like I'm missing something lol I wonder if we can find something like that at an audio place?
 
Advertisement

 
63 - Late Model Restoration - 1
Advertisement
Top