Advertisement

Digital Instrument Cluster go blank?

Discussion in 'Issues, Repairs, Warranty, TSB, Recalls' started by wustang, Dec 10, 2018.

  1. wustang

    wustang Member

    Vehicle(s):
    2018 Mustang EcoBoost Premium
    Joined:
    Aug 26, 2018
    Location:
    Houston, TX
    Posts:
    6
    Likes Received:
    0
    0   0   0
    I have a 2018 EcoBoost Premium with the digital dash and was driving home tonight when the instrument cluster abruptly went blank without warning. Car continued to drive as normal. The screen magically reappeared about 3 seconds later and all seemed well again. Anyone else had this happen? Thanks.
     
  2. ChaoticFury09

    ChaoticFury09 Well-Known Member

    First Name:
    Nathan
    Vehicle(s):
    2019 GT Premium (Automatic - Magnetic)
    Joined:
    Jul 27, 2018
    Location:
    Toronto Ontario
    Posts:
    663
    Likes Received:
    227
    0   0   0
    I believe there was a TSB about this. I would run it to a dealer and have them make sure you have the latest firmware for it.
     
  3. Balloonatic84

    Balloonatic84 New Member

    Vehicle(s):
    2019 Mustang GT Orange Fury - On Order!
    Joined:
    Jun 15, 2018
    Location:
    Bicester
    Posts:
    4
    Likes Received:
    1
    0   0   0
    Does anyone happen to know the TSB that was raised for this and/or have a link to it? My new UK-spec GT has a similar issue but hasn't left the dealership yet, they believe they need to order an entire new cluster but if there is a firmware update that may resolve the issue I want to make sure they've covered that off.

    Currently being told a new cluster cannot be ordered until Jan 7th, so its going to be a long wait!
     
  4. ChaoticFury09

    ChaoticFury09 Well-Known Member

    First Name:
    Nathan
    Vehicle(s):
    2019 GT Premium (Automatic - Magnetic)
    Joined:
    Jul 27, 2018
    Location:
    Toronto Ontario
    Posts:
    663
    Likes Received:
    227
    0   0   0
    I found it for you but I am not sure it is the same issue as what you are having. See below.

    2018 Ford Mustang ELECTRICAL SYSTEM:INSTRUMENT PANEL/SOFTWARE

    Year: 2018 Mustang

    NHTSA Campaign #: 17V814000

    Date Announced: DECEMBER 18, 2017

    Summary: Ford Motor Company is recalling certain 2018 Ford Mustang vehicles equipped with an automatic transmission and a 12.4" digital instrument cluster. If the ignition is turned off when the transmission is not in PARK, the instrument cluster may not illuminate the PRNDL gear position display and the operator may not receive the "Key in Ignition" chime when the driver's door is opened. As such, these vehicles fails to comply with the requirements of Federal Motor Vehicle Safety Standard (FMVSS) number 102, "Transmission Shift Lever Sequence/Starter Interlock/Transmission Braking Effect, " and number 114, "Theft Protection."

    Actions: Ford will notify owners, and dealers will update the instrument cluster software, as necessary, free of charge. The recall is expected to begin February 5, 2018. Owners may contact Ford customer service at 1-866-436-7332. Ford's number for this recall is 17C21.
     
  5. Balloonatic84

    Balloonatic84 New Member

    Vehicle(s):
    2019 Mustang GT Orange Fury - On Order!
    Joined:
    Jun 15, 2018
    Location:
    Bicester
    Posts:
    4
    Likes Received:
    1
    0   0   0
    Thanks for taking the time to respond - I found this one too but agree that I don't think this is the same issue - Mine is also a manual.

    I didn't get to experience the issue first hand but from what I've been told it seems exactly as Wustang has described.

    Going to be a long wait it seems!
     
  6. ChaoticFury09

    ChaoticFury09 Well-Known Member

    First Name:
    Nathan
    Vehicle(s):
    2019 GT Premium (Automatic - Magnetic)
    Joined:
    Jul 27, 2018
    Location:
    Toronto Ontario
    Posts:
    663
    Likes Received:
    227
    0   0   0
    Hope it gets resolved for you soon. It’s a beautiful display once it’s working.
     
  7. biscuit60177

    biscuit60177 Member

    First Name:
    Craig
    Vehicle(s):
    2019 Mustang GT PP1
    Joined:
    Sep 25, 2018
    Location:
    South Elgin, Il
    Posts:
    16
    Likes Received:
    8
    0   0   0
    I've never had that happen thankfully. I have had issues with the color changes I make not staying and always reverting back to the default blue no matter what I try. I wonder if there are larger issues that need to be addressed with the system as a whole.
     
  8. StynkyLomax

    StynkyLomax Member

    First Name:
    Steve
    Vehicle(s):
    2019 Mustang GT Premium 10R80
    Joined:
    May 31, 2019
    Location:
    PA
    Posts:
    10
    Likes Received:
    7
    0   0   0
    Interesting

    I washed my vehicle today and as I went to move it I started it up and got a completely blank digital cluster along with a Ford Pass alert saying "Restraints indicator lamp warning". I heard some extra ding noises but couldn't see anything due to the blank cluster. A few start cycles didn't bring it back. I unhooked the negative battery cable and waited about 30 seconds and BOOM back on. Anyone else get a blank dash at start-up? I'll be taking it to the dealership Monday for a free oil change so I'll mention the issue.
     
  9. Ginger1

    Ginger1 Member

    Vehicle(s):
    2018 Ecoboost Premium
    Joined:
    Jun 30, 2019
    Location:
    Northern NJ
    Posts:
    23
    Likes Received:
    4
    0   0   0
    Yep. Same thing happened tonight. Center stack screen with HVAC and radio controls was fine, but instrument panel was blank. Unhooked the battery and went back to normal. 18 EcoBoost Premium w/10 Speed.
     
  10. Groovy

    Groovy Member

    Vehicle(s):
    2019 GT Premium PP M6 Magna Ride
    Joined:
    May 16, 2018
    Location:
    DFW Texas
    Posts:
    16
    Likes Received:
    7
    0   0   0
    I had the display go out once while driving. Stayed off about 10 seconds then came back on. Strange!
     
    Vinay likes this.
  11. DetroitMustang

    DetroitMustang Well-Known Member

    Vehicle(s):
    2018 Mustang GT Premium A10
    Joined:
    May 16, 2019
    Location:
    Roseville, Mi
    Posts:
    45
    Likes Received:
    21
    0   0   0
    Mine went black today, came back on in about 5-10 seconds. This is the second time.
    The first time was soon after I bought it last year and less then 1000 miles on it.
    I have almost 20,000 now. It seems OK, I'm thinking maybe an update through WiFi ?? Maybe it just needed a reboot.
    It really kind of scared me both times.......
     
  12. mosher

    mosher New Member

    First Name:
    moshe
    Vehicle(s):
    S550 2018 GT PP
    Joined:
    Sep 22, 2019
    Location:
    CA
    Posts:
    3
    Likes Received:
    0
    0   0   0
    2018 gt Digital Cluster go blank.
    Firmware update,battery reset,all done.does not work.
    Any new insights in the forum.
    thanks
     
  13. gnatsuM

    gnatsuM Well-Known Member

    Vehicle(s):
    2019 Mustang GT
    Joined:
    Apr 23, 2018
    Location:
    Ontario
    Posts:
    100
    Likes Received:
    81
    0   0   0
    Had this happen 3 times over the past month at highway speed. Display blanks for 5 sec or so. Took it into dealership and they said there's no TSB and could find no fault code.
     
  14. JJJ

    JJJ Well-Known Member

    Vehicle(s):
    2019 Mustang GT
    Joined:
    Oct 31, 2015
    Location:
    Florida
    Posts:
    100
    Likes Received:
    48
    0   0   0
    Mine happened yesterday fo 10 seconds, went to dealership this morning and told the same - no TSB. Maybe corrupt software? Thought they would have reloaded software to try.
     
Loading...

Share This Page