2017 GT350 Warm Idle Tick

Nichiari2020

Member
Joined
May 21, 2020
Posts
12
Reaction score
0
Location
Gilbert, AZ
Vehicle(s)
2017 GT350
Hey all,

Recently purchased a CPO 2017 GT350 and am loving it so far. I have noticed a pronounced tick at idle, that seems to go away as soon as you touch the throttle. I realize that it is probably normal but I would love to get a little reassurance from the experts! I should also mention that my oil level is perfect. I found a video that sounds exactly the same and will attach it to this post.

Thanks
smile.png







Advertisement

 
OP

Nichiari2020

Member
Joined
May 21, 2020
Posts
12
Reaction score
0
Location
Gilbert, AZ
Vehicle(s)
2017 GT350
  • Thread starter
  • Thread Starter
  • #5
As of now I haven't noticed any consumption. It is nice to hear that the tick is normal though.
 

Rubyred17

Well-Known Member
Joined
Nov 10, 2018
Posts
237
Reaction score
87
Location
Kentucky
First Name
Dan
Vehicle(s)
2017 GT350
Hey all,

Recently purchased a CPO 2017 GT350 and am loving it so far. I have noticed a pronounced tick at idle, that seems to go away as soon as you touch the throttle. I realize that it is probably normal but I would love to get a little reassurance from the experts! I should also mention that my oil level is perfect. I found a video that sounds exactly the same and will attach it to this post.

Thanks
smile.png


Hey all,

Recently purchased a CPO 2017 GT350 and am loving it so far. I have noticed a pronounced tick at idle, that seems to go away as soon as you touch the throttle. I realize that it is probably normal but I would love to get a little reassurance from the experts! I should also mention that my oil level is perfect. I found a video that sounds exactly the same and will attach it to this post.

Thanks
smile.png


Yes, my 2017 does the same thing. Have you changed oil lately?
 
OP

Nichiari2020

Member
Joined
May 21, 2020
Posts
12
Reaction score
0
Location
Gilbert, AZ
Vehicle(s)
2017 GT350
  • Thread starter
  • Thread Starter
  • #7
Yes, my 2017 does the same thing. Have you changed oil lately?
I just bought her on Friday and the dealer did an oil change when reconditioning for the CPO status. That was around 400-500 miles ago.
 

Tomster

Beware of idiots
Joined
Feb 20, 2016
Posts
10,859
Reaction score
9,171
Location
FL
First Name
Tom
Vehicle(s)
'20 RR GT500R(CFTP), 18 OW GT350R Base, '17 AG GT350R Electronics Pack, '97 PG Cobra Convertible
I just bought her on Friday and the dealer did an oil change when reconditioning for the CPO status. That was around 400-500 miles ago.
Just make sure the dealer put enough oil in the engine. Sometimes they think its a 5.0

Keep an eye on the oil. Every time you fill up is the recommended frequency.
 
OP

Nichiari2020

Member
Joined
May 21, 2020
Posts
12
Reaction score
0
Location
Gilbert, AZ
Vehicle(s)
2017 GT350
  • Thread starter
  • Thread Starter
  • #9
Just make sure the dealer put enough oil in the engine. Sometimes they think its a 5.0

Keep an eye on the oil. Every time you fill up is the recommended frequency.
Yeah I'm pretty anal about my oil level. Been checking most everyday and it's staying at the top of the hashmarks after waiting 15 mins with a warm/hot engine.
 

Rubyred17

Well-Known Member
Joined
Nov 10, 2018
Posts
237
Reaction score
87
Location
Kentucky
First Name
Dan
Vehicle(s)
2017 GT350
I just bought her on Friday and the dealer did an oil change when reconditioning for the CPO status. That was around 400-500 miles ago.
Please check your message for more info but I have found this noise to be pretty common. It scared me at first but so far mine is running great and the noise diminishes as the oil get some mileage on it. If you google "5.0 coyote engine tick" you will find lots of threads about this (I realize this is not a Coyote but same basic architecture)
 
OP

Nichiari2020

Member
Joined
May 21, 2020
Posts
12
Reaction score
0
Location
Gilbert, AZ
Vehicle(s)
2017 GT350
  • Thread starter
  • Thread Starter
  • #11
I got around to capturing a video of my car this afternoon. It sounds a little different than the original video I found, less ticky and more rattle-esque. I am hoping that it is still deemed normal and I can stop being paranoid!

 

Rubyred17

Well-Known Member
Joined
Nov 10, 2018
Posts
237
Reaction score
87
Location
Kentucky
First Name
Dan
Vehicle(s)
2017 GT350
I got around to capturing a video of my car this afternoon. It sounds a little different than the original video I found, less ticky and more rattle-esque. I am hoping that it is still deemed normal and I can stop being paranoid!

Drive it !!
Run it up to 7500 a time or two after the oil is hot and listen to it- I bet it’s quiet
 

Frank.Herbst

Well-Known Member
Joined
Nov 4, 2018
Posts
392
Reaction score
315
Location
Denver, CO
First Name
Frank
Vehicle(s)
2019 GT350
What color is your Shelby. I sold a 17 back to Ford that always ran great. No oil issues. It had an error code for taking to long to warm up. That's it, other wise it was a great car. Liked it so much I got another one.
Best if luck.
 
OP

Nichiari2020

Member
Joined
May 21, 2020
Posts
12
Reaction score
0
Location
Gilbert, AZ
Vehicle(s)
2017 GT350
  • Thread starter
  • Thread Starter
  • #15
What color is your Shelby. I sold a 17 back to Ford that always ran great. No oil issues. It had an error code for taking to long to warm up. That's it, other wise it was a great car. Liked it so much I got another one.
Best if luck.
Ruby red with black stripes, it's actually Rubyred17's cars twin!
 

Advertisement





 
199 - Racer X Fabrication


Advertisement
Top