Gen 5 whipple tearing belts

Discussion in 'Forced Induction - 5.0L V8 Engine' started by 5ohcoyote, Jun 1, 2020.

  1. 5ohcoyote

    5ohcoyote Well-Known Member

    First Name:
    Nick
    Vehicle(s):
    2016 mustang GT
    Joined:
    Sep 5, 2019
    Location:
    El Paso, TX
    Posts:
    71
    Likes Received:
    26
    Occupation:
    Infantry
    0   0   0
    Has anyone else had issues when installing a gen 5 on a 15-17?

    ive contacted whipple, checked the spacers, checked belt size and tension and I’m still tearing belts. It’s currently 6 rib on 3.5 pulley. There’s one spacer for the tensioner pulley that’s a bit smaller it measured .36 when it should be .375, whipple said that shouldn’t be the issue.

    I can get the belt to seat right, but once I start it the belt gets pushed forward on one idler pulley and once I go wot the belt turns into a 4 rib.
     
  2. crcpdx

    crcpdx Well-Known Member

    First Name:
    Charlie
    Vehicle(s):
    2018 Mustang GT
    Joined:
    Aug 12, 2018
    Location:
    97008
    Posts:
    222
    Likes Received:
    102
    0   0   0
    IDK, I have an 18, but that sounds like a spacer issue.
     
  3. OP
    OP
    5ohcoyote

    5ohcoyote Well-Known Member

    First Name:
    Nick
    Vehicle(s):
    2016 mustang GT
    Joined:
    Sep 5, 2019
    Location:
    El Paso, TX
    Posts:
    71
    Likes Received:
    26
    Occupation:
    Infantry
    0   0   0
    That’s what I thought and whipple swore that wasn’t the issue
     
  4. crcpdx

    crcpdx Well-Known Member

    First Name:
    Charlie
    Vehicle(s):
    2018 Mustang GT
    Joined:
    Aug 12, 2018
    Location:
    97008
    Posts:
    222
    Likes Received:
    102
    0   0   0
    You could try a bigger spacer and see what happens. I remember a thread where guys just played with different spacers until they found what worked. If you were going to upgrade anyway, you could go the gates/ griptech route?
     
    5ohcoyote likes this.
  5. OP
    OP
    5ohcoyote

    5ohcoyote Well-Known Member

    First Name:
    Nick
    Vehicle(s):
    2016 mustang GT
    Joined:
    Sep 5, 2019
    Location:
    El Paso, TX
    Posts:
    71
    Likes Received:
    26
    Occupation:
    Infantry
    0   0   0
    *measured .375 and supposed to be .390. Just double checked. 523F914C-2D0F-4D41-AF16-0027E0853664.jpeg
     
    crcpdx likes this.
  6. db252

    db252 Equinsu Ocha

    Vehicle(s):
    16 GT Premium/PP/Nav
    Joined:
    Jan 1, 2016
    Location:
    Bay Area, CA
    Posts:
    1,333
    Likes Received:
    714
    Rating:
    100%
    4   0   0
    Definitely an alignment issue. Go through the manual and double check every pulley and idler install.
     
    5ohcoyote likes this.
  7. AZ_whippleS550

    AZ_whippleS550 Well-Known Member

    First Name:
    Douglas
    Vehicle(s):
    2016 mustang GT
    Joined:
    Jan 6, 2020
    Location:
    AZ
    Posts:
    92
    Likes Received:
    34
    0   0   0
    One of those pulleys is for sure off, later I will take a picture of mine and post here.
     
    5ohcoyote likes this.
  8. Avispa

    Avispa Well-Known Member

    First Name:
    Richard
    Vehicle(s):
    2016 Mustang GT/CS convertible
    Joined:
    Dec 5, 2019
    Location:
    Oldsmar, FL
    Posts:
    328
    Likes Received:
    185
    0   0   0
    Doesn't happen often, but it does happen, Whipple may not have pressed the drive hub correctly onto the blower drive shaft. It doesn't take much misalignment to shred belts. Have seen that once in a blue moon on water pumps.
     
    5ohcoyote likes this.
  9. dbranger94

    dbranger94 Well-Known Member

    First Name:
    Daniel
    Vehicle(s):
    Magnetic 2015 GT
    Joined:
    Jul 7, 2015
    Location:
    Indiana
    Posts:
    266
    Likes Received:
    40
    0   0   0
    Not sure if you installed OPGs or a lower crank timing sprocket, but you may check the balancer is all the way back if it's ever been removed. You should also use a ruler or yard stick to check that all the pulleys, especially the grooved ones, are in the same plane.
     
    5ohcoyote likes this.
  10. OP
    OP
    5ohcoyote

    5ohcoyote Well-Known Member

    First Name:
    Nick
    Vehicle(s):
    2016 mustang GT
    Joined:
    Sep 5, 2019
    Location:
    El Paso, TX
    Posts:
    71
    Likes Received:
    26
    Occupation:
    Infantry
    0   0   0
    Yup pretty sure it was the balancer. I was about to order the gates laser to see which one was off, but it was pretty obvious. Guess the last shop didn’t torque it down all the way after fixing my timing issue. Appreciate the help guys!
     
    TX-Ripper, sigintel and crcpdx like this.
  11. dbranger94

    dbranger94 Well-Known Member

    First Name:
    Daniel
    Vehicle(s):
    Magnetic 2015 GT
    Joined:
    Jul 7, 2015
    Location:
    Indiana
    Posts:
    266
    Likes Received:
    40
    0   0   0
    Glad to hear you got it figured out.
     
    5ohcoyote likes this.
  12. FastCarFanBoy

    FastCarFanBoy Well-Known Member

    Vehicle(s):
    2013 GB GT
    Joined:
    Feb 21, 2016
    Location:
    FL
    Posts:
    723
    Likes Received:
    489
    0   0   0
    Be glad it was shredding belts because that crank snout was probably not long for this world.
     
Loading...

Share This Page