2017 GT Air Fuel Ratio - Lurching Problem - Please help!!

zstoppa

New Member
Joined
Sep 13, 2021
Messages
1
Reaction score
0
Location
Kansas City Missouri
First Name
Zach
Vehicle(s)
2017 Mustang GT
Hello, 2017 Mustang GT. Mods consist of: Roush CAI (tune required, ventrili tube removed), Corsa Extreme Catback, Catless long tubes, 91 octane tune from SCT. And its autotragic.

My car will accelerate just fine and have no problem as long as I am accelerating. It's just whenever I am maintaining speed that the problem begins. Also I think the idle is a little rough? Not really too noticible but definatly not idling "Comfortably" if that makes sense.

The problem is whenever I am remaining constant without applying much pressure to throttle. My RPM will stay the same, speed will stay roughly the same, but my car does this whole lurching thing where it acts like I take my foot off the gas but I am remaining constant. It's really noticeable whenever I turn my cruise control on because it keeps RPM exact. It goes back and forth like it's lurching or losing power then normal then losing power etc.. I notice my Air/Fuel ratio spikes whenever this happens from its normal resting of 13.7-14.8 ish it'll spike up to 15, 16, 17,18, sometimes 19,20 and then back to 12ish then spike back to normal then spike up and repeat the process, whenever its spikes is when it does the loss of power thing. - MY RPM IS NOT SPIKING. Tuning shop today told me my MAF is also doing the same thing, they pinned two tiny holes in the CAI for whatever reason the previous owner had because it was a very small leak right behind MAF. They said even with holes filled, and new MAF it didn't fix the issue. So they are back to square 1...

A couple weeks ago, I woke up and my car was dead. It had sat for 2 weeks as my front bumper was off because I was waiting for my new gt500 style front bumper to ship. Long story short I was an idiot and borrowed my friend's battery from her Subbie and put it in and hooked it up. But the terminals were backwards since it was from a Subbie and I didn't consider that so I plugged terminals in opposite and my horn went off really loud, took it off and found out I had it backwards. Thats what started this whole fucking ordeal was I had an electrical surge that fried my main fuse the 250a/125a mega fuse under the battery terminals in the fuse box. Everything inside my car that was plugged in either fried or blew its fuse.. I am praying to god nothing else is fried.. But I don't know what to do. Ford won't do anything since it's got a tune & no cats. I have put 100 miles on my car in about 2.5 months, I am getting so frustrated and angry about not being able to drive my car.. Any and all advice/tips are welcomed. I just want my stupid car fixed >_<

Thank you!!
 

Jackson1320

Well-Known Member
Joined
Sep 26, 2019
Messages
1,862
Reaction score
584
Location
California
First Name
Jaxson
Vehicle(s)
2015 mustang gt
Check the alternator output. If it’s damaged it can do this
 
Advertisement

 
18 - Vossen Wheels - 1
Advertisement
Top