STFT swinging/Idle Stumble post cam install.

gcadorette13

PoopStang
Joined
Mar 29, 2017
Threads
2
Messages
102
Reaction score
32
Location
Missouri
Vehicle(s)
2016 Mustang GT
Currently on a base tune after I installed cams on my 2016. After the car warms up it idles really rough and usually dies. STFT's swing about 30% both ways. The only changes I made was the cams and the fews parts that go along with that. No CEL's

Car ran pretty good before the cams. It has new O2's, brand new MAF. The CJ has been on the car for a few years so i don't think it's a vacuum leak from that. I have removed the intake a couple times in hope that it was something that simple. Logs are showing cams are at 0 during idle so it might not be the phasers or solenoids. I am thinking of replacing the solenoids just because they are pretty cheap.

Kind of at a loss on what to try next for troubleshooting. I want to rule out everything before I just take it to a shop. What do you guys think?

 

mejohn50

Intergalactic Snail
Joined
Jun 12, 2016
Threads
17
Messages
351
Reaction score
235
Location
United States
First Name
Mitch
Vehicle(s)
2019 Mustang GT
A data log would be helpful. Have you asked the tuner?

You said the MAF is brand new…is it backwards?
 
Last edited:
OP
OP
gcadorette13

gcadorette13

PoopStang
Joined
Mar 29, 2017
Threads
2
Messages
102
Reaction score
32
Location
Missouri
Vehicle(s)
2016 Mustang GT
A data log would be helpful. Have you asked the tuner?

You said the MAF is brand new…is it backwards?
I will take a long data log today to send off and I'll toss it on here. The MAF is installed correctly.
 


MKL_DS

Well-Known Member
Joined
Dec 11, 2020
Threads
7
Messages
262
Reaction score
166
Location
Central Forida
First Name
Mike
Vehicle(s)
2020 GT PP1
Can’t expect a base tune for cams to be on point. Gonna take a log or 2 to dial in idle and drivability.
 

EFI

Well-Known Member
Joined
May 19, 2015
Threads
61
Messages
4,032
Reaction score
2,757
Location
Masshole central
Vehicle(s)
5.Br0
Sounds like that base tune is not quite right for your setup and will need some adjustment from your tuner.

That would be my first point of contact about this, not the forums.
 
OP
OP
gcadorette13

gcadorette13

PoopStang
Joined
Mar 29, 2017
Threads
2
Messages
102
Reaction score
32
Location
Missouri
Vehicle(s)
2016 Mustang GT
Sounds like that base tune is not quite right for your setup and will need some adjustment from your tuner.

That would be my first point of contact about this, not the forums.
That's what I'm thinking. I loaded up the old 93 tune that I knew worked and it idles waaayyyy better. I can tell the cams are not the happiest while driving, but it's a good starting point.
 
OP
OP
gcadorette13

gcadorette13

PoopStang
Joined
Mar 29, 2017
Threads
2
Messages
102
Reaction score
32
Location
Missouri
Vehicle(s)
2016 Mustang GT
Can’t expect a base tune for cams to be on point. Gonna take a log or 2 to dial in idle and drivability.
That's starting to makes sense. I was hoping it would idle at least, but we're working through it.
 

 
15 - Steeda - 1
Top