Psychotic last night: newer Mustang engine quit.

16RRGT

Roush Phase 1
Joined
Aug 14, 2016
Messages
82
Reaction score
14
Location
SW Washington
Vehicle(s)
16 GT; 85, 69 Camaro, 2000 F350 Dsl Dually
16 GT A6 w/Roush SC. 2450 miles or so.

Raining pretty good around here... temp about 60 degrees.

Leave my house, drive about half a mile, and the engine dies while I'm driving. (Just took a left turn from one road to another.)

Pull over. Hit the start button, the engine starts... sorta... but it's running like crap. When I pushed the throttle, it leaned out (20.0 on the a/f mixture) and when I just let it idle... chugging... (the a/f mixture bouncing around between 11 and, say, 16.)

When I put the car into gear, at first it would just die. I got it moving, slowly, another block or two to get it off the main drag.

At this point, the engine would idle but the a/f mixture bounced around again.

I was thinking water managed to get into the TB sensor circuit and the computer didn't really know what was going on. Of course, it threw a bone on the panel.

We called AAA. 2 Hour wait. Meanwhile, thinking that perhaps the issue was water related, I let the engine run (felt like 6 cylinders) for 10 minutes to get it warmed up... still idling rough.

I pop the hood, look around... nothing out of place and the engine does not appear wet in any way.

Drop the hood. Get back into the car. Shut the engine off. Start it back up.... runs like a little Ford clock.

CEL bone has disappeared, a/f ratio number at or around 14, engine idles smooth as glass...put it into gear, keeps running great, like normal, drive it around the large (rural) block (maybe a mile) and it's running fine.

I know it threw a code, but it certainly was transient. Drove the car to our destination about 8 miles away. Did our business, drove the car to our next stop, maybe 5 miles away, took care of stuff there (two hour wait) still raining... got in the car and drove it home with no problems.

At some point today, I'll get the codes read. But I'm kinda looking for the areas of concern to look out for and any help/ideas would be appreciated.
 

Terminator2

Well-Known Member
Joined
Apr 21, 2016
Messages
1,963
Reaction score
446
Location
Spring Hill Florida
First Name
David
Vehicle(s)
2016 Mustang GT Premium
16 GT A6 w/Roush SC. 2450 miles or so.

Raining pretty good around here... temp about 60 degrees.

Leave my house, drive about half a mile, and the engine dies while I'm driving. (Just took a left turn from one road to another.)

Pull over. Hit the start button, the engine starts... sorta... but it's running like crap. When I pushed the throttle, it leaned out (20.0 on the a/f mixture) and when I just let it idle... chugging... (the a/f mixture bouncing around between 11 and, say, 16.)

When I put the car into gear, at first it would just die. I got it moving, slowly, another block or two to get it off the main drag.

At this point, the engine would idle but the a/f mixture bounced around again.

I was thinking water managed to get into the TB sensor circuit and the computer didn't really know what was going on. Of course, it threw a bone on the panel.

We called AAA. 2 Hour wait. Meanwhile, thinking that perhaps the issue was water related, I let the engine run (felt like 6 cylinders) for 10 minutes to get it warmed up... still idling rough.

I pop the hood, look around... nothing out of place and the engine does not appear wet in any way.

Drop the hood. Get back into the car. Shut the engine off. Start it back up.... runs like a little Ford clock.

CEL bone has disappeared, a/f ratio number at or around 14, engine idles smooth as glass...put it into gear, keeps running great, like normal, drive it around the large (rural) block (maybe a mile) and it's running fine.

I know it threw a code, but it certainly was transient. Drove the car to our destination about 8 miles away. Did our business, drove the car to our next stop, maybe 5 miles away, took care of stuff there (two hour wait) still raining... got in the car and drove it home with no problems.

At some point today, I'll get the codes read. But I'm kinda looking for the areas of concern to look out for and any help/ideas would be appreciated.
MAF got soaked with water most likely.
 

Advertisement





 
5 - Hypermotive - 1


Advertisement
Top