Official Tesla-Style Head Unit

2017PPGT

Well-Known Member
Joined
Mar 3, 2017
Messages
55
Reaction score
6
Location
Louisiana
First Name
Rick
Vehicle(s)
2017 PP GT w/ H-Pipe & Catback
I mean an installl video
Advertisement

 

RVK

Well-Known Member
Joined
Feb 6, 2017
Messages
123
Reaction score
11
Location
WA
Vehicle(s)
2015 Ford Mustang Ecoboost Premium
Well, I finally got Liu to give me a refund as soon as he receives my returned (broken) unit. I'm out of this game, too many issues reported with the Premium Mustang. It's a real shame, but I guess I'll stick with the crappy Sync 2 system for now. I'll leave the Wiki up for folks who need the info. Let me know if you want an account to actually contribute there, so you can keep the info going. Otherwise, I'm out. Thanks all!
 

2017PPGT

Well-Known Member
Joined
Mar 3, 2017
Messages
55
Reaction score
6
Location
Louisiana
First Name
Rick
Vehicle(s)
2017 PP GT w/ H-Pipe & Catback
Sorry to hear that RVK.

It's nearly 2 a.m. and after hours of wondering what's going on after I got to it so quickly, StangATX realized I was missing a harness. I'm beyond disgusted but grateful for the help on this forum.
 

Fray_s550

Well-Known Member
Joined
Jan 13, 2017
Messages
180
Reaction score
41
Location
California
Vehicle(s)
Ford Mustang S550 V6
Message is still there because I need to explain that now there's 2 Generation. If you go to the Tesla's APK Manager you'll see firmware update (1st Gen) and Firmware Update (2nd Gen) You'll have to go on the 2nd gen. There's already an update available. Don't really need to do it though. I still need to modify the Engrish like the 1st gen for the Radio and Phone. Then I'll modify the Launcher to show the new Theme.

So is there a major difference between 1st gen and 2nd gen? I'm sorry I havent been following the thread for a while because of work and stuff.
 

firestarter2

Well-Known Member
Joined
Jun 16, 2016
Messages
3,205
Reaction score
1,159
Location
NYC
Vehicle(s)
RR G350 Track
Sorry to hear that RVK.

It's nearly 2 a.m. and after hours of wondering what's going on after I got to it so quickly, StangATX realized I was missing a harness. I'm beyond disgusted but grateful for the help on this forum.
That sucks I want to make sure I have all of mine can you tell me which it is you are missing I have a base.
 

elpatronvega

Active Member
Joined
Mar 6, 2017
Messages
36
Reaction score
10
Location
Chicago
Vehicle(s)
2017 mustang v6
Sorry to hear that RVK.

It's nearly 2 a.m. and after hours of wondering what's going on after I got to it so quickly, StangATX realized I was missing a harness. I'm beyond disgusted but grateful for the help on this forum.
I have all the wires you have and my unit is working perfectly I don't understand, did he say which one exactly?
 

soldier989

Well-Known Member
Joined
Mar 26, 2016
Messages
1,129
Reaction score
230
Location
Columbus OH
Vehicle(s)
2017 GTPP Premium
Well, I finally got Liu to give me a refund as soon as he receives my returned (broken) unit. I'm out of this game, too many issues reported with the Premium Mustang. It's a real shame, but I guess I'll stick with the crappy Sync 2 system for now. I'll leave the Wiki up for folks who need the info. Let me know if you want an account to actually contribute there, so you can keep the info going. Otherwise, I'm out. Thanks all!
Sorry to hear this. I've actually been thinking about going to a SYNC 3 unit. I do like the Tesla, but I miss all the buttons.

Are you at all willing to trade the little AC on/off board with mine? Mine works and such, but the 1 LED doesn't. I can't imagine this would be tested or impair your return.
 

RVK

Well-Known Member
Joined
Feb 6, 2017
Messages
123
Reaction score
11
Location
WA
Vehicle(s)
2015 Ford Mustang Ecoboost Premium
Sorry to hear this. I've actually been thinking about going to a SYNC 3 unit. I do like the Tesla, but I miss all the buttons.

Are you at all willing to trade the little AC on/off board with mine? Mine works and such, but the 1 LED doesn't. I can't imagine this would be tested or impair your return.
I already shipped it back a week ago, sorry.
 

elpatronvega

Active Member
Joined
Mar 6, 2017
Messages
36
Reaction score
10
Location
Chicago
Vehicle(s)
2017 mustang v6
I still can't change boot up screen any help? Tried multiple restarts but just can't get it to change...
 

donmcgowen

Well-Known Member
Joined
Dec 13, 2016
Messages
266
Reaction score
42
Location
Chicago
Vehicle(s)
2015 Mustang GT, D1 Procharger Stage 2
Tesla in Premium

So here is a site that sells that "Tesla" unit. I'm sure most have seen this. Anyway, they claim this works with the Premium.

http://www.i-5autohaus.com/product-page/navigation-screen-for-2015-2016-ford-mustang

I messaged them and this is their response. I'm curious what is different with this unit that makes it work with Premium.

Below is the quick conversation
-----------------------------------------------------------------------------

Do you have the cables to make this work with Premium GT. A friend says this will not work with GT Premium cars.
12 hours ago

Yes, we do have cables for all Premium models now
12 hours ago

100% guarantee that it works with Premium? I have heard they do not get audio or backup camera working
12 hours ago

Yes. We recommend go to a local audio shop for installation. However, we provide technical support if you wish to give it a try.
Please make sure you select GT and premium package on the product page when you ready purchase.
 

2017PPGT

Well-Known Member
Joined
Mar 3, 2017
Messages
55
Reaction score
6
Location
Louisiana
First Name
Rick
Vehicle(s)
2017 PP GT w/ H-Pipe & Catback
That sucks I want to make sure I have all of mine can you tell me which it is you are missing I have a base.

I'm gonna post a pic of all the wires and the way they're supposed to be connected to the back of the HU that was sent from their engineer himself. I have to get to laptop and am at work.
 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
So I have mine in. And it's great just haven't messed with it yet. Reverse and blue tooth and everything works. Trying to change the start up screen now. Only complaint is the radio is very fuzzy. Which plug on the back of the Gen2 is the antenna? I know there is a blue connector and white connector. I am going to try gps now while connected to the wifi next to my house
 

Oakley_5OH

Well-Known Member
Joined
Jun 13, 2015
Messages
103
Reaction score
15
Location
Philadelphia, PA
First Name
Charles
Vehicle(s)
2016 Ford Mustang GT- Deep Impact Blue
Also, I changed in settings from C* to F* but it didn't change? I remember seeing the fix but searching threw 150+ pages is a nightmare. Anyone know where else I have to change it ?
 

2017PPGT

Well-Known Member
Joined
Mar 3, 2017
Messages
55
Reaction score
6
Location
Louisiana
First Name
Rick
Vehicle(s)
2017 PP GT w/ H-Pipe & Catback
So I have mine in. And it's great just haven't messed with it yet. Reverse and blue tooth and everything works. Trying to change the start up screen now. Only complaint is the radio is very fuzzy. Which plug on the back of the Gen2 is the antenna? I know there is a blue connector and white connector. I am going to try gps now while connected to the wifi next to my house
Blue connector is gps and i ran mine into the glove box.
 

2017PPGT

Well-Known Member
Joined
Mar 3, 2017
Messages
55
Reaction score
6
Location
Louisiana
First Name
Rick
Vehicle(s)
2017 PP GT w/ H-Pipe & Catback
I've been at work all day but here is a quick update.
The wire they forgot to give me is an RCA and wouldn't affect sxreen coming on, so that is not the problem.
The HU A/C and pilot switches work, just not the screen.
It has been confirmed that I have everything connected correctly.
I checked the fuse in the car and it was fine, so that has been ruled out.
I will check the fuse on the HU when I get home and if that isn't it then the manufacturer says the brain is no good and I'll have to return it.
Pretty frustrating considering I was very laid back and wanted them to take their time and makensure it was ok.
My worse nightmare was having to ship it back out and it looks like a reality now.
I have to thabk StangATX for all of his help, as he went above and beyond.
I will definitely be donating again!

For anyone who wants the pic of oroper wire install, just hit me uo on what'sapp @ 504-421-5277.

Install is very very easy and it would've been an hour job with front camera if unit was working properly.
So no worries.
Hope I'm the only unfortunate one.
 
Advertisement

 
89 - Solo Performance - 1
Advertisement
Top