Curiouser and curiouser

CANTWN4LSN

Well-Known Member
Joined
May 17, 2015
Threads
13
Messages
658
Reaction score
259
Location
northwest
Vehicle(s)
2017 GT350
Well an interesting thing has happened with my 2017 GT350. Now has 35,000 miles and have driven it the same manner the entire life of car (let's just say a radar detector and a lot of spirited driving when it's safe). Although initial oil use was one quart at 3300 miles, had settled down to one per 1200-1500 miles since except for once at 800 miles but after replacement of oil pan gasket under warranty back up to usual.
Since last oil change 1500 miles ago, all of a sudden it has only used 1/4 of a quart. Two observations. First is the last oil change done at dealership where all mine have been done lead to them having to use NAPA substitute for the FL2087 as they had removed the old filter without realizing they didn't have the OEM (even though I called ahead to ensure they did:facepalm:) and they assured me it was fine. The second is that since then, whether related or not, my oil pressures have been running higher than they were before although still well within normal range under load, when cold and at rest.
Can't understand why higher oil pressures would lead to less consumption if this was a blow by or valve stem issue. Not sure of the mechanics as to why a different filter would lead to higher pressure (?more restrictive flow) which I would think would exacerbate the two conditions above. Or perhaps, unrelated, my rings have finally "seated" which I suppose could translate to a higher crankcase oil pressure? Will be interesting to see what happens at next oil change and going back to the OEM filter.

 

DCShelby

Well-Known Member
Joined
Jan 24, 2019
Threads
16
Messages
1,045
Reaction score
751
Location
DC
First Name
Robert
Vehicle(s)
2018 GT350 Leadfoot Grey
Sounds like its running strong!
 

 
MBGRAM-2
Top