changing my Eco-boost engine for a Gen 3 Coyote 10 speed in a 2015 chassis, it is the first one?

whatdoyoufeedit?

Well-Known Member
Joined
Jan 14, 2015
Posts
556
Reaction score
194
Location
Fayetteville, NC
Vehicle(s)
2019 Race Red EB A10 (Formerly 2016 3X Yellow V6 M6), 1996 Mercury Cougar XR7 4.6L A4 (Future Coyote swap candidate)
Never doubted it could be done, the swap just makes too much sense; excellent job! :beer:
 

koldrid

Well-Known Member
Joined
Nov 6, 2019
Posts
58
Reaction score
21
Location
CA
First Name
Kyle
Vehicle(s)
2019 Ford Mustang Bullitt
Curious to see if everything is working or if there's still a lot of work to be done in the computer. Great Job.
 
OP
The RedMus

The RedMus

Well-Known Member
Joined
May 15, 2020
Posts
120
Reaction score
85
Location
Miami
First Name
Diego Certified
Vehicle(s)
2015 Mustang 50 Year Edition
  • Thread starter
  • Thread Starter
  • #215
Curious to see if everything is working or if there's still a lot of work to be done in the computer. Great Job.
I just got everything programmed and everything works like from factory, I got the line lock, the remote starter, all the modes works perfectly, the shifting is amazing, this engine definitely moves!! I need to get tuned to turn off the check engine because the O2 sensors that I removed because the catless long header, orden than that all works like from factory like I said.

onces i finish that i will post all the modules and parts that is necessary to replace or reprog to get this done.

20201004_103943.jpg
 

Interceptor

Daily Driver
Joined
Apr 3, 2018
Posts
1,206
Reaction score
642
Location
Low country South Carolina
First Name
John-David
Vehicle(s)
2019 California Special A10
That would make a great transplant in an older Ranger pick up, or Pinto
 
OP
The RedMus

The RedMus

Well-Known Member
Joined
May 15, 2020
Posts
120
Reaction score
85
Location
Miami
First Name
Diego Certified
Vehicle(s)
2015 Mustang 50 Year Edition
  • Thread starter
  • Thread Starter
  • #223
OP
The RedMus

The RedMus

Well-Known Member
Joined
May 15, 2020
Posts
120
Reaction score
85
Location
Miami
First Name
Diego Certified
Vehicle(s)
2015 Mustang 50 Year Edition
  • Thread starter
  • Thread Starter
  • #224
hey guys! a little update: i am using the car daily and it works fantastic, my MPG it is low right now "14.7mpg" mainly because i floor it very often and also maybe because i did not retune the ECU with the new mods so i assuming that the mixture is not the best, i just notice a few days ago that i have a stupid problem with the BCM, when i turn on the positions lights all the lamps works except the front position lamp (same as turn signal and turn signal works) and tail lamp (stop and turn signal works) so i was looking for it and it is not a fuse for that, this signal coming straight from the BCM so it is a matter of programming, so i tried to re-flash the as-build on both BCMs and still nothing! this is weird because i did not change the BCM, it was the same as the car came with it, but not sure if it was reprogrammed at the dealer, so i spoke with the guy in Ford of Kendall and he told me that maybe doing a firmware update of the BCM module will fix this, but not sure when can i go to there! i heard about flashing lights problem or stop light outage but not position light outage on front and back! any one got this problem before? or knows something about it? some help is well appreciate it!
 

Idaho2018GTPremium

Well-Known Member
Joined
Nov 20, 2018
Posts
939
Reaction score
597
Location
Idaho
Vehicle(s)
2018 Mustang GT Premium A10 w/ PP1 and MagneRide
I can't help you with your flashers issue (I think that's what you're talking about...?), but I'm glad that you finally got this thing running. It's been a long time coming; waiting for everything. Good things come to those who wait!

And...that thing must be LOUD.
 
 
101 - Anderson Composites - 1
Top