Car turned off while turning at super slow speed. 15 GT Auto

clevernickname

Well-Known Member
Joined
Nov 18, 2014
Messages
1,107
Reaction score
89
Location
BC, Canada
Vehicle(s)
2015 Magnetic Mustang GT, 2016 camaro ss (gfs), 2015 range rover sport, 2013 ford explorer, 2017 WRX
No engine mods. Car at 36000 kms, i'm first owner.

Temperature was about 8 degrees celcius.

Gas tank was about 1/4 full.

Never happened before, no similar issues.

8000km-10000km oil changes at ford. Not tracked. Last oil change about 8000km ago.

What happened: I was pulling out of a driveway at super slow speed, as I turned onto the main road from the driveway, car felt like it stalled, and suddenly there was beeping like a door was open chime. I didn't spend time trying to see error messages cause traffic was approaching. I put into park, e brake, turned engine off, then on, and it was fine. Has this happened to anyone else???? What should I do..

It was during the moment I was turning, foot off accelerator cause I didn't want to curb the front chin as driveway is uneven, as I accelerated (i think) or maybe before I did that is when the car turned off. I mean I must've a little since I was about 45 degrees onto the road.

Car had been driving everyday for the past week, and had just been parked for 2-3 hours (had driven it 2-3 hours before).





Advertisement

 
OP
clevernickname

clevernickname

Well-Known Member
Joined
Nov 18, 2014
Messages
1,107
Reaction score
89
Location
BC, Canada
Vehicle(s)
2015 Magnetic Mustang GT, 2016 camaro ss (gfs), 2015 range rover sport, 2013 ford explorer, 2017 WRX
  • Thread starter
  • Thread Starter
  • #2
Bump :/
 

jbanh100

Well-Known Member
Joined
Jun 4, 2019
Messages
96
Reaction score
21
Location
Houston
First Name
Jackie
Vehicle(s)
2019 Mustang GT Premium
No engine mods. Car at 36000 kms, i'm first owner.

Temperature was about 8 degrees celcius.

Gas tank was about 1/4 full.

Never happened before, no similar issues.

8000km-10000km oil changes at ford. Not tracked. Last oil change about 8000km ago.

What happened: I was pulling out of a driveway at super slow speed, as I turned onto the main road from the driveway, car felt like it stalled, and suddenly there was beeping like a door was open chime. I didn't spend time trying to see error messages cause traffic was approaching. I put into park, e brake, turned engine off, then on, and it was fine. Has this happened to anyone else???? What should I do..

It was during the moment I was turning, foot off accelerator cause I didn't want to curb the front chin as driveway is uneven, as I accelerated (i think) or maybe before I did that is when the car turned off. I mean I must've a little since I was about 45 degrees onto the road.

Car had been driving everyday for the past week, and had just been parked for 2-3 hours (had driven it 2-3 hours before).
Might be a stupid question but by no engine mods, you mean no tune also right? I am tuned and if I slow down into a turn and blip the throttle there's a change the rpm's drop low enough to stall out. This is normal according to Lund when I asked. Try sitting in your car and tap the accelerator quickly and then let go and see if the rpm's go up and then drop below normal idle. Again sometimes when performing this action, the rpms rise, drop below 720-750 (idle range) maybe to like 400 or 500, then climb back up to normal idle range. Also sometimes it will rise, drop significantly to 400 or 500, but instead of going back up to idle range it just stalls out and I have to restart the engine. This is from my experience.
 
OP
clevernickname

clevernickname

Well-Known Member
Joined
Nov 18, 2014
Messages
1,107
Reaction score
89
Location
BC, Canada
Vehicle(s)
2015 Magnetic Mustang GT, 2016 camaro ss (gfs), 2015 range rover sport, 2013 ford explorer, 2017 WRX
  • Thread starter
  • Thread Starter
  • #5
Yup no tune.
 

Advertisement





 
22 - Velgen Wheels - 1


Advertisement
Top