Bad water Pump! Not Front main seal as thought

Kong76

Well-Known Member
Joined
Apr 23, 2016
Threads
42
Messages
1,892
Reaction score
427
Location
Turlock, Ca
Vehicle(s)
2016 Ingot Silver GT
Decided to do an engine check tonight and found oil inside my harmonic balancer pulley. Upon further inspection there is oil on my sway bar and lower plastic engine guard. I grabbed a flashlight and saw what looks like fresh oil behind the crank pulley up against the timing chain covers. Now I had my timing chain tensioners replaced about 6 months ago. I have been having this weird rotational chirping sound coming from the engine at crawl speed and when turning off engine( slowly comes to a stop).

I have just had problem after problem with this completely stock car. 30k miles on the clock. I am going to take it to a different dealer even though the one I bought the car from is 2 miles up the road. I am losing faith in their mechanics. Found half ass work before.

 
OP
OP

Kong76

Well-Known Member
Joined
Apr 23, 2016
Threads
42
Messages
1,892
Reaction score
427
Location
Turlock, Ca
Vehicle(s)
2016 Ingot Silver GT
Well I was wrong, looked like oil and smelled like oil but called dealership and it was coolant leaking from a bad water pump. Might explain why the car felt so shifty driving with the AC on during these past few 100 degree days. Luckily I check engine compartment once a week.

Might also explain the chirping sounds at crawl speed. Never got a check engine light.
 

 
22 - Velgen Wheels - 1
Top