Bad Tune?

H00CH90

Well-Known Member
Joined
Jul 14, 2019
Threads
5
Messages
45
Reaction score
22
Location
NA
Vehicle(s)
Mustang GT
So I recently ran into an issue when trying to get my car ready for emissions. The past few years I haven't needed to pass emissions so I ran catless longtubes. Now I need an emissions test so I installed some cats and loaded my emissions tune from Lund. The car feels like it runs well on the emissions tune but I'm seeing a number of codes (P0300, P0302, P0304, P0016). Sometimes this will trigger a check engine light, but not usually. The car doesn't feel like it's misfiring at all and my non emissions tune does not pop any codes. I've swapped plugs and coils to rule those out and it hasn't changed. Lund thinks it's odd but doesnt seem to know what is going on. I was about to just sell the car but I love it too much to just give up on it. I'm considering retuning with another company, I just need to pass emissions. I've tried crank relearn, didn't seem to help. I was down about 2 quarts of oil, added the difference and it took a little longer for the codes to return but not much. Anyone seen this before?

Car has an Edelbrock R2650, ID1050X, VORTECH BAP, Brisk RR12S, TSP longtube headers.

 
Last edited:

Genxer

Well-Known Member
Joined
Oct 16, 2014
Threads
12
Messages
1,560
Reaction score
701
Location
Texas
Vehicle(s)
2015 Mustang GT / Perf pack / DIB
Vehicle Showcase
1
When a crank relearn is needed it will pop a P0315.
Also, you can have no CEL and still fail an inspection. Once they get your codes cleared, drive it for a few days, and then hook your car up to a scanner to check for any monitors that are not reset.
 
Last edited:

Temovic55

Well-Known Member
Joined
May 29, 2019
Threads
4
Messages
179
Reaction score
58
Location
Saudia Arabia
Vehicle(s)
GT500 2014, ROUSH II 2018
Vehicle Showcase
1
I went with the same scenario a while ago.
ALL of those codes disappeared when shifting to another tuner! Some tuners really appreciate taking the time reading the logs unlike others!
Still on revisions right now but no more hiccups, stall, Misfire...car drives like stock and pull insane.
 
OP
OP

H00CH90

Well-Known Member
Joined
Jul 14, 2019
Threads
5
Messages
45
Reaction score
22
Location
NA
Vehicle(s)
Mustang GT
I got the same setup as you I don't have any problems
Lund tuned? I'm hoping it may be a bad VVT solenoid but I'm just getting started tracking down the problem.
 

 
51 - American Racing Headers - 1
Top