19 Mustang GT PP1 Renegade Euro Lights

Discussion in 'Mustang S550 General Forums' started by jchamp922, Jun 2, 2020.

  1. jchamp922

    jchamp922 Member

    Vehicle(s):
    2019 Mustang GT PP1
    Joined:
    Jun 2, 2020
    Location:
    USA
    Posts:
    6
    Likes Received:
    2
    0   0   0
    Hi,
    New to forum. Just purchased a 19 GT PP1 Oxford white a few weeks ago. I installed the Renegade series Euro clear lights and I am having an issue. Every time I hit the brake it is causing radio station static. Was wondering if anybody else experienced this problem. Never had this issue before with after market tail lights. Thanks IMG_20200527_141206_01~2.jpg
     
  2. The_Don_72

    The_Don_72 Well-Known Member

    First Name:
    Don
    Vehicle(s):
    2019 Ruby Red 5.0 Mustang GT 6MT
    Joined:
    May 2, 2020
    Location:
    Brisbane, Australia
    Posts:
    93
    Likes Received:
    28
    0   0   0
    Sorry can't help, but just thought I'd say that here in Australia all Mustangs come with the clear lights as standard. Ain't they purdy compared to the reds? :)
     
  3. Bikeman315

    Bikeman315 Well-Known Member

    First Name:
    Ira
    Vehicle(s):
    2019 Mustang GT/CS
    Joined:
    Apr 12, 2015
    Location:
    Myrtle Beach, SC
    Posts:
    5,557
    Likes Received:
    4,294
    Occupation:
    Retired
    0   0   0
    Since this is a pure plug & play installation you can most likely eliminate wiring as an issue (unless you accidently nicked a wire during installation). My thought is a defect in one the brake light section of the taillights. Have you tried disconnecting one than the other to see if that eliminates the issue?
     
  4. OP
    OP
    jchamp922

    jchamp922 Member

    Vehicle(s):
    2019 Mustang GT PP1
    Joined:
    Jun 2, 2020
    Location:
    USA
    Posts:
    6
    Likes Received:
    2
    0   0   0
    I sent them back to the company and waiting on a new set. Thanks
     
    Bikeman315 likes this.
Loading...

Share This Page