10 month, 10,000 mile review

LowFlying65

Well-Known Member
Joined
Dec 1, 2020
Threads
6
Messages
127
Reaction score
222
Location
92123
First Name
David
Vehicle(s)
FJG Mach1 # M3579
Hands down the best money I ever spent! Haven't enjoyed driving this much since I was 17 in my '69 Firebird. Sometimes I wonder what it would have been like to get the HP and/or Tremec. But then I remind myself I would have probably wrapped it around a telephone pole by now, and I'm in traffic way too much.

Mine has everything I could need and then some. The leather seats are some of the most comfortable I've ever had.

Track Attack and the Track Tour were fun times. Highly recommend them if you can. Oil changes are as easy as any car I've owned. Gas mileage isn't as bad as I feared... as long as I'm not getting on it too much. Get propositioned to race on the freeways from time to time. Too wise for that game... most of the time. Get compliments nearly daily from all kinds of people. Plan to keep my Mach 1 a long, long time.

Only issue is my Spotify music and Nav cuts out often when plugged into the dash USB port. Anyone else having that problem.

20210916_155913.jpg
Besides that, no issues.

Hope your first 10,000 miles go as well as mine.

 

superspartan

Well-Known Member
Joined
May 2, 2022
Threads
30
Messages
151
Reaction score
106
Location
Dubai
Website
www.hidevolution.com
First Name
Spartan
Vehicle(s)
2021 Mach 1 FJG, Chassis# M5590
Only issue is my Spotify music and Nav cuts out often when plugged into the dash USB port. Anyone else having that problem.
No sure how you connect your phone, I have my phone which is a Google 6 Pro (Android Auto) connected via USB under the armrest and it never disconnects. I use Spotify and Waze or Google maps all the time
 

murick

Well-Known Member
Joined
Jul 5, 2021
Threads
5
Messages
520
Reaction score
572
Location
Prague, Czech Rep.
First Name
Richard
Vehicle(s)
2021 Euro Mach 1
Only issue is my Spotify music and Nav cuts out often when plugged into the dash USB port. Anyone else having that problem.
If you by any chance have an Android phone and Android Auto on it, you might be facing the problem I had:

When I connected my phone (Huawei Mate 10) to the head unit with a USB cable, Sync3 detected Android Auto on the phone and paired the phone over BT with the head unit without any intervention.

The problem was that BT pairing was set for all connection types: "Call audio", "Media audio" and "Message access", by default, but for some reason "Media audio" never worked for me correctly (music in my Neutron player, or speech in Waze navigation). I had to manually disable "Media audio" in the BT pairing config on the phone (once it has been set up by the car and connected at the same time). Since then it worked as expected.

I even tried to debug it with the help of the author of Neutron player, but it looked like a bug in either the phone (Android) or Sync3.

The downside of this is that if you do not connect the phone over the USB and use only BT pairing, you will be missing the audio over BT.
 
Last edited:
OP
OP
LowFlying65

LowFlying65

Well-Known Member
Joined
Dec 1, 2020
Threads
6
Messages
127
Reaction score
222
Location
92123
First Name
David
Vehicle(s)
FJG Mach1 # M3579
If you by any chance have an Android phone and Android Auto on it, you might be facing the problem I had:

When I connected my phone (Huawei Mate 10) to the head unit with a USB cable, Sync3 detected Android Auto on the phone and paired the phone over BT with the head unit without any intervention.

The problem was that BT pairing was set for all connection types: "Call audio", "Media audio" and "Message access", by default, but for some reason "Media audio" never worked for me correctly (music in my Neutron player, or speech in Waze navigation). I had to manually disable "Media audio" in the BT pairing config on the phone (once it has been set up by the car and connected at the same time). Since then it worked as expected.

I even tried to debug it with the help of the author of Neutron player, but it looked like a bug in either the phone (Android) or Sync3.

The downside of this is that if you do not connect the phone over the USB and use only BT pairing, you will be missing the audio over BT.
Thanks for the tips. It connects fine with BT most of the time. I'll give this a try.
 

cheeser

Well-Known Member
Joined
Sep 25, 2021
Threads
9
Messages
193
Reaction score
304
Location
Colorado
Vehicle(s)
21 Mach 1, 4Runners and RAV4's
Track Attack and the Track Tour were fun times. Highly recommend them if you can. Oil changes are as easy as any car I've owned. Gas mileage isn't as bad as I feared... as long as I'm not getting on it too much. Get propositioned to race on the freeways from time to time. Too wise for that game... most of the time. Get compliments nearly daily from all kinds of people. Plan to keep my Mach 1 a long, long time.
.
.
.

Hope your first 10,000 miles go as well as mine.
I pretty much agree with everything you mentioned....except for oil changes.

The filter removal mess has been my issue....have been able to reduce the mess with bendable funnels / aluminum foil. I understand there are ways to manipulate items to reduce the mess, but oil still seems to find the gap and drips on everything.

Looking forward to the 3D printed filter funnel to see if that fits tighter and makes this process more convenient.
 

 
63 - Late Model Restoration - 2
Top