Search results

  1. Instrument+Dash Screen Flicker/Malfunction

    They don’t, almost never at the same time. The instrument gauge flickers and eventually goes out. I’m hoping it’s something like just the harness, think I might have to just bring it into the dealership. I have a third party warranty from EasyCare that I was going to cancel, but it might be...
  2. Instrument+Dash Screen Flicker/Malfunction

    That’s what I thought too, before I bust out my voltmeter and solder-iron to check connections, the main 8’ Sync3 display is also displaying similar characteristics- which makes me hesitant to rip out the instrument cluster. I’d love for the problem to be an instrument-cluster failure, so I’d...
  3. Instrument+Dash Screen Flicker/Malfunction

    Hi all, I purchased a GT a few weeks ago and it’s been great until this week when the instrument cluster screen started flickering/turning off mid-drive. Issue: instrument cluster screen starts flickering mid-drive, and eventually shuts off. After parking for awhile and starting again, it turns...
  4. Abnormal Roush Axle back and X-pipe noise- need a 2nd opinion

    Thanks man appreciate it! It sounds like it’s vibrating/needs a rubber dampener on some of the hangers- idk if I’m tripping but the exhaust tone sounds pretty different than the videos/audio I’ve heard online. Had my mechanic take a look at it and checked it was bolted on tight. I’ve only got a...
  5. Abnormal Roush Axle back and X-pipe noise- need a 2nd opinion

    Looking for any help. I have a 2016 Mustang V6 and just had my Roush Axle backs and a flowmaster x pipe installed at a shop. I had a second mechanic verify that the bolt ons are tight, but I’m getting a weird rattling sound/vibration on cold starts/idling and driving at low speeds. I have some...
  6. 2015 Mustang V6 Exhaust Sound Clip Thread

    Looking for any help. I have a 2016 Mustang V6 and just had my Roush Axle backs and a flowmaster x pipe installed at a shop. I had a second mechanic verify that the bolt ons are tight, but I’m getting a weird rattling sound/vibration on cold starts/idling. I have some pretty bad drone on the...
Advertisement
Top